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HFSS使用经验谈 
http://www.mweda.com 

1. 系统概述 
 
HFSS--High-Frequency Structure Simulator 
本指南是对有一些无源结构高频模拟经验，但对 HFSS 是新手的工程师编写的，它提

供了对软件全貌的概述，它通过对设计例子从结构绘制，观察，三维问题的电磁解及简单

结构的分析来介绍软件。 
本教程中的例子，说明了软件的许多重要特性，例子分析文件及软件本身提供了一个

直观的具指导意义的几何实例及结果，当使用本教程时请参考这些范例。 
本材料仅给初学者一些基础知识，HFSS 软件的详细的培训教程，可以登陆微波 EDA

网查询，网址 http://www.mweda.com。 
 
纵观 
本章节介绍了软件的情况，给出了软件概貌，对工程模块的绘制，定义，电磁解及分

析等基本步骤作一些简述。 
什么是 HFSS： 
它是三维无源结构模块电磁分析软件包。 

 它可以计算多个模式的散射参数（S-parameters） 
 电场的分布，包括天线远区场的辐射模型 
 对多个模式计算阻抗和传播常数 

HFSS的绘图界面（它是建立在 AutoCAD绘图工具基础上的）可以绘制任何所感兴趣
的模型的几何结构，或者可从其他多个工业标准文件中读入三维几何结构。 
模型的端口，材料及边界的确认后，给定频率及精度，就可以解相应的电磁场，由解

出的相应数据，进行后处理后可以得到。 
 S，Y，Z参数矩阵，归一化的内在 S矩阵 
 每个端口的阻抗和复传播常数（对某个模式） 
 生动的有层次的场分布图 
 幅度相位的多曲线图 
 矢量和轮廓图 
 二维或三维远场图 
 场量与距离对照图 
 Smith圆图 
 数据表 

 
高速精确模拟与造型 
传统的电路的造型和分析包括，二维绘图加工测试，称为“Cut-and-try”，既修改--试

验。有了 HFSS软件后，可以用计算机完成此过程 
你可以用此软件修改一个模型或从零件库中取出零件组成新的模型，可以任意角度观

察模型。其次确定模型的材料，端口和边界条件。给定频率或扫频范围，进行电磁特性分

析。 
 可给定模型的数目 
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 输入的电压和电流 
 收敛的判拒，不论是对整个 S矩阵或是给定 S 参量对这个端口任意模式 
 解的类型：为一频率，扫频，快速扫频 

 
本软件有许多数据处理能力可供选择 
所存储的参量可供其他电力模拟器读取，比如 EESof或系统设计软件。 
本软件的使用，无需数字电磁专门知识。 
 
软件特点 
1． 使用Maxwell’s方程解包含色散的电场和磁场。 
2． 可以在个人计算机或 UNIX平台上运行。 
3． 使用 AutoCAD工业标准界面来处理无限制几何结构。可含无限介质和端口。 
4． 软件具备固态的模型零件库，其中有预先绘制好的参数化的模块如滤波器，弯头，

带线，电容等，使得复杂的结构的创建变得迅速而简单，这些模型都是数字化的，所以你

可以修改数据以适应自己的需要。 
5． 在任何端口对任意模式，一使用者给定的精度技术 S参数。 
6． 当材料是有耗时，可以计算其损耗值。 
7． 快速扫频观察电磁响应。 
8． 包含一工作控制界面，可用以建立长时间的模拟，不论四本地或遥控模拟，以优化

计算机资源的使用时可以检查收敛进程。 
 提供有层次的生动的可视场模型图，场的绘制及制表能力。 
 可动态旋转视图以获得最佳视角。 
 给出（天线）模型的辐射。 

 
建模及分析步骤 
结构建模：输入几何结构，定义其材料，端口和表面。 
绘制几何模型： 
1． 绘制结构图。 
2． 可用 undo命令，返回原步骤，以改正操作。 
3． 最后的绘成的图可以加以层次，改变视角。 
4． 如图中包含常用零件，则可从哭中迅速调用它 
定义材料： 
在几何模型图绘制完成后，可以定义材料的性质。定义可从库中材料中选择，也可输

入自己的材料。可输入的参量有介电参量，磁导率，如果材料是有耗的还可以输入导电率，

如为电阻还可以输入电阻率。 
定义端口和边界： 
第二步是定义结构的边界，定义和校准端口。边界的类型包括完善磁或电导，磁或电

对称边界，导电边界，电阻边界：或是辐射边界。端口可以是波导，同轴导体或是事实上

的任一种传输线。可以为每个感兴趣的端口或模画出阻抗，校准和极化线。软件系统会计

算每一端口的场解，并提供如同阻抗等有用的数据。 
计算 S-参量 
模拟器使用称为有限元分析法的数字方法计算场量和 S参数。 
通过接的对话框，使用者可以确定在某一个频率或扫频带上计算广义散射参数，S 参

量可对某一端口的阻抗进行归一化。 
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如果你在一电路板模拟中计划使用这些 S-参量可用简单的菜单命令对其用 50Ω重新归
一化。 
采用一适当细化的有限元网络，可使模型结果满足使用者的精度要求。 
为了快速，用二维分析结构的端口，这时应指定仅端口解（ports-only solution）。 
为了快速预览结构的频率响应，可选择快速频率扫描，这种方式节省时间，是用一等

频率解的结果，通过有理函数的近拟得到某一频带内的电响应。 
结果分析 
在模拟结束后，可以计算模型的散射参数，用系统提供的后处理功能，可以显示数字

结果及用图出场的分布。 
利用端口表面平面颜色深度的变化可在屏幕上提供生动的波传播及电磁特性的画面。 
 
 

2.绘制模型的几何外型 
 
本章给出 HFSS绘画特性，在给出的例子中使用了许多命令，这些命令在绘图，编辑，

多视角观察中都是可用的。 
 
需要思考的事： 
HFSS是一分析软件，它可以核实你的无源结构的电磁特性设想，虽然 HFSS中的绘画

工具是灵活的，几乎任意结构都可以画，模拟应是可实现的，并应在分析软件的能力范围

之内。 
注意以下几个一般规则： 

 环绕结构几何模型的封拦将自动记入封装效应，使得封入的模型具有一可实现的尺
寸，当画微带线时，建议微带到外部封拦不小于 5个基片厚度。 

 当模拟开放区域时： 
如天线和辐射问题，解时封拦围绕着天线，并标明封拦是一辐射边界，吸收边界靠近

结构，并可以是任意形状。 
 除非定义了一个激励源，否则结构至少应有一个端口，在无端口时，可在结构中加

一源，如无源，至少应有一端口以便进行测量。 
 不能模拟二极管，晶体管等有源器件 
在结构中不能加直流偏量。 
对金属导电率可以是无穷大，也可以是有限的。 
电导率，介电率，介电常数可以是实数或复数，复介电常数主要是为了说明损耗正切。 
结构中不能有可移动的零件。 

 移动零件不能直接模拟，但可以通过不同的几何结构来推断，运动零件的电磁效应。 
 应保持结构电尺寸尽可能小 
软件模拟每一点的电磁场，为节省计算机资源，应使模型结构的尺寸合理。 
当结构变得复杂时在给定的计算机上，会引起误差。 
好的规则是将模拟对象的尺寸，限制在几个波长之内。 
可以将电尺寸较大的物体沿传播方向分割为几个部分分别模拟，以得到整个模型的尺

寸。 
 
其他考虑： 
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由于算法本身是通过解麦克思韦方程来进行的，因而在计算时间和计算机存储方面要

求很高，在绘制模型的几何图时应记住： 
 结构应尽可能简单。模拟矩形结构比圆形简单，如某一面积如无电路上的特别要求，

请将图形画成方角以节省内存 
 利用对称结构，利用对称特性可以节省模拟时间和所需内存。 

 
绘制工作前的准备 
心中应想好要画的图形，在纸上先画出一草稿图，包含相关的尺寸。 
考虑好结构的每一零件，因为可能要画剖面图 
如结构较复杂，给出组成结构的部件列表。 
应记住重要的是模拟结构内部空间，这里是电磁波通道而不是结构的壁。 
当一些复杂的结构不重要时，可以简化。如角落的小平面，弧线，不必近似为曲线。

金属导体可用二维物体来表示，而不用画成三维的。 
 
绘图举例 
 
在本部分我们用一步一步的指导画下面的模型作为例子： 

 同轴 T型结 
 微带低通滤波器 
 角锥天线 
 螺旋天线 

本章给出的命令是一个基础，使用它们你可以画出使用者自己的模型图。 
同轴 T 绘制较简单，它使用到许多有用的绘图命令如单位，基本，薄片等。应

记住你模拟的是两个导体之间介质空间而非导体。在绘制中内部导体用“drilled 
out”。我们感兴趣的是内外部导体之间的空间，其中的介质定义为空气抽去的内圆
柱作为内部边界，在缺省时为完善导体。 （2-6） 

 
同轴节的绘制，分为以下步骤： 

 以 z为轴线，画内外三维圆柱。 
 以 y为轴线，画内外三维圆柱。 
 分别联接以 z轴，y轴为轴线的外圆柱和内圆柱。 
 抽去内导体，从外部零件，组合物体。 
 沿 y-z平面，将目标沿对称面切开。 

下面给出绘图细节 
2-8 
 
设立项目 
在准备同轴 T 型节的绘制时，创建一个项目并给以命名，并设置相关参量：如

绘制网格，单位，光标扑捉选项。 
注意：虽然我们推荐你自己完成此例的绘制，但如你在不打算现在完成它，请参

考“Examples”文件目录下的 pre-drown例子。 
本例子项目名称为 coaxt 
创建并命名项目： 
要命名一个新项目，操作如下： 
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1． 运行（HFSS）软件，则显示“项目管理”对话框。 
2． 在此对话框列表中点击“new”则显示“新项目对话框”。 
3． 在“new project”中键入“coaxtee”。 
4． 按“return”键或点击 OK。 

这样在 pro文件目录下就建立一个名为 coaxtee的目录，所有与 coaxtee项目相关
的文件都将保存在此目录下。目录名可以根据使用的意愿使用其他目录,这时显示使
用者所选的项目对话框。 
设置项目选择项： 
项目选择对话框的显示是一缺省项，它提示你设置你的单位及网络设置。 

2-9  对本例（同轴线 T型节），设置如图 2。2所示。 
然后点击“ok”，这时显示主屏幕，注意这时所得项目名称显示在主屏幕的标题栏上。 
 
绘制 Z-轴同轴线 
 
在这一小节我们的任务是 z-轴同轴线，在 x-y平面上绘出内外导体。 
因为 x-y平面是一缺省平面，所以不用首先定义他画外导体圆柱。 

1． 点击主菜单上的Model—Draw，这时绘制屏幕会展示出来。 
2． 点击 3D Objects中的 Cylinder，注意这时会在窗口底部的文本柱中显示信

息，提示你选择柱的中心。 
3． 在 x-y区域移动光标，并点击左键以确定圆柱中心。 
不用担心光标的位置，你在点击柱外点后可显示一对话框，所有的圆柱坐标在

点击左键确定后都可以重新设置。 
另一方法是在HFSS屏幕底部的文本框中键入它们的坐标以进入2D或3D项目。 
在下一个例子，低通滤波器的设置中，就是用这种方法。 
4． 从你所选择的中心点开始移动光标，注意到此时有一圆显示在屏幕上，当

你向不同方向移动光标时，此图会增大或缩小。 
5． 点击鼠标左键以确定圆的大小，在对话框中你可以调整它的大小。 
6． 参考图 2-3中的对话框，可对原点尺寸及其他数据进行调整。 

其中 Dimensions中的“regment angle”是指对圆周多等分分割时，单一等分所对应
的圆心角，这里对 voaxtee选定的是 15度。 
注意：对许多结构而言，要进行精确的 S 参数分析，选择 30 度或更精的分割也是

可行的。 
关于选项、“world or local coordinates” 
“world coordinate”是固定的笛卡儿坐标，x,y,x轴以确定在二维或三维空间中的位

置。而使用 local coordinate system ，给定原点的位置和指向以及 UV平面，然后你可
以移动或旋转局部坐标。 
在对话框中显示出了项目的属性，注意在项目名称一项。虽然系统会给出一个缺省

的名称，但给出你自己的更有特色的名称是有益的。在图 2-3中，项目的名称是 xycylout，
此名称表明所定义的项目是外导体圆柱，并且在 x-y平面。 
另外还可以进行显示颜色的更改。 
定义项目中的材料也是容易的事，可点击一种材料，并在“use in simulation”中核

对。 
由于此时的对象并不代表整个同轴线，不用担心是否在模拟中使用它或对它进行材

料定义。 



http://www.mweda.com             专业提供 ADS,HFSS等微波仿真软件及其学习教程 

 6

当对话框的填写内容使你满意后，点击“OK”，这时圆柱就会创建在 x-y 平面上，
如图 2-4所示。 
编辑参数化的对象 
在 HFSS中，对象的参数（尺寸，位置，片割角度等）会随所绘的对象保存下来。

可对这些参数进行参考和对其进行编辑以改变其结构。对象的参数化对结构的调整是

非常方便的，使我们达到所期望的电响应，或者进行（what-if）分析。 
对大多数 2D和 3D对象，起参数是与对象一并保存的，除非你删除了此对象。 
仅为编辑的目的也可以与结构一起保存一对象。 
对象可设置为不可视化的或设置为不参与模拟，也可以两者都选择，这需使用

Edit>Visible和 Edit>Simulation命令。 
对同轴线 T型结例子，用于创建完整的同轴线的圆柱可与结构一起，作为参数化的

对象保存。 
修改对象： 

1． 从绘画平面选择 Edit>对象参数，这时显示参数化信息对话框。 
2． 双击你所要编辑的对象，这时会显示一对象模板。 
3． 进行你所打算修改的参数的编辑，完成后点击 ok。 

注意：由其他对象产生的对象，如连接成一体化所生成的对象，对这些生成的

对象不要进行参数保存。只有那些用于一体化或连接的对象可进行参数保存。 
另外使用多边形命令生成的多边形不可进行参数化处理。（2.13） 
 
内导体的绘制。 

内导体的绘制过程与外导体相同，仅尺寸不同，名称 xycylin 用于描述 T 位于 x-y
平面上的内导体，如图 2-5 
图 2-6给出了内外导体的同轴线。 
 
绘制 y轴同轴线 
要画 y轴同轴线，即将同轴线的内外导体绘制在 x-z平面中。你需要首先设置绘制

区域以显示此平面。 
设置 x-z平面 

1． 从绘制屏幕，选择菜单命令 Define>Plane Set,这时平面表显示出来。 
2． 选择 XZ平面，点击 OK 
这时，x-z平面中显示出网格点阵。 

 
绘制 x-z平面中的内外导体 
内外导体圆柱的绘制，如同前面 z轴同轴线的绘制。 
选择 3D Object>Cylinder，并给定中心，外部轮廓线，使用图 2-7中的数据 
对内部导体，选择图 2-8中的数据， 
（2-20） 

 
使用一体化命令以创建 Tee结 
要使用 z向同轴线和 y向同轴线，创建一同轴线结，就要使用 3D Object>Unit命令。 

1． 点击 3D Object>Unit，出现 Unit对话框。 
2． 从 3D对象表中点击 xycylout及 xzcylout。 
3． 在对象名字栏中，键入一更具特色的名称如 coaxout。 



http://www.mweda.com             专业提供 ADS,HFSS等微波仿真软件及其学习教程 

 7

4． 点击“ok”。 
一体化的同轴线外导体显示在屏幕上，如图 2-10。 
5． 再次选择 3D Object>Unit命令。 
6． 这些点击对象 xycylin和 xzcylin，命名为 coaxin。 
7． 点击“ok” 
此时内部导体一体化组成同轴线的内导体，最后结果显示与 2-9图。 
 
同轴线切片 
当结构中的电场和磁场存在对称关系时，我们将沿对称将结构切开，解电磁问

题仅处理切剩的一半，或者在绘图就画一半或 1/4 或结果的一小部分，而精确模
拟整个结构，这样可节省时间，磁盘或内存空间。但应清楚结构的对称性并不意

味其中的电场和磁场一定具有对称性。 
对同轴 T型结，当沿 y-z轴切开时磁场具备完善的磁对称。这样解所需时间更

小，所需磁盘空间也小。 
剖切命令： 

1． 点击 Edit>Slice出现剖切对话框。 
2． 从 3D对象列表中，选取 coaxtee。 
3． 从平面列表中，点击 YZ平面。 
4． 点击 OK。 

如图 2-11所示，仅正 X方向的一半保留。 
 
由外部圆柱 T型结构中抽去内圆柱 T型 

如同本章开始时所述（图 2-1）建模所感兴趣的面积是电磁场传播区域即内外导体之
间，因此，使用抽取命令从外导体中抽取内部圆柱导体。也可以想像钻去内部圆柱，而

得到完善导电壁。 
命令： 

1． 点击 3Dobject>Subtract---对象抽去对话框出现。 
2． 从 3D对象芯类表中选取 coaxout。 
3． 从抽去 3D对象列表中选取 coaxin。 
4． 在对象名称一栏键入 coaxtee。 
5． 选取 use in simulation。 
如此有疑问，不必担心，你可以选择编辑它：Edit>Simulation，而得到再

次修改此项的机会。 
6． 在材料选择栏点击空气。 
如对选择材料有疑问，不用担心，可以在以后再次指定材料。（在主平面当

你设置边界条件时）。 
7．击 OK。 
系统在导体抽取时会暂停相应。最后显示的图虽然与外部 T型结 
 
保存同轴结 
在绘制图时，特别是绘制较复杂图形时，不时保存绘制结果是一个好的习惯。 
从 File>save保存文件。 
用 File>Return main返回主屏幕，这时对象模拟对话框显示出来如图 2-12。表中给那些

对象是可视的，以及被选中进行模拟的对象。 
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所有的用来建立其他对象的对象都与此对象一并保存，除非你明确地删除它们，虽然它

们未列在此表中，同时也不可视。 
如你需要它们以建立新的对象，可对其参数进行编辑，显示出的图会被自动更新。 
在本例中，被剖切的同轴结在对话匡中出现这是因为它是创建的最终对象。 
你可以定义材料，端口，及边界（仅用于本对象），也仅用于此对象的模拟中。 
确认 coaxtee对象是用于模拟的。 
点击 OK保存信息，并返回主屏幕。 
这样，就完成了同轴 T型结的绘制。 
 
绘制微带低通滤波器 
 
本节介绍微带低通滤波器的绘制。图 2-13给出了微带低通滤波器的尺寸及端口的位置。 
对此例，由于其磁对称性，我们仅画其 1/2。首先画两个盒体，一个在另一个上，分别

代表空气和微带基片，然后在微带基片上画二维滤波器微带。 
使用下面一般命令绘制微带低通滤波器： 

 建立对象。 
 绘制安放 1/2大小的长立方体代表微带线。 
 在其上绘制另一长方体代表空气层。 
 绘制 1/2的低通滤波器微带线。 

本节给出了上面操作的每一步。 
建立对象 
为了准备绘制微带低通滤波器，首先要创建并命名对象，设置相应的参数。 
注：我们建议你使用本教材，绘制出次微带低通滤波器。但如果你现在不

打算绘制，你可以参考 examples 目录下，预先以给定好的例子，此目录包含
了本教材中所有例子，本例子的对象的名为 ms-lpf。 

 
创建和命名对象 
为创建命名一个对象的操作如下： 
1． 运行本系统软件，此时回展现对象管理对话框。 
2． 在对象列表中，点击“new”，新的对象对话框将展现出来。 
3． 在新对象栏中键入对象名称“lpfilter”。 
4． 回车或点击 OK 
这时一子目录名为 lpfilter见创建在对象目录下（缺省情况）。所有也 lpfilter
对象相关的文件都将保存在此目录下。 
如你不希望运用缺省目录，可以修改或建立新的目录。一旦建立目录，这

时所选的对象对话框会呈现出来。 
当你选择了一个新的对象后，此对象的显示是一种缺省安排，这时回出现

提示，要你输入单位，为近似仿真你的对象的网格的安排。 
5． 对本例使用的设置如图 2-14所示。 
6． 点击 OK，这时主屏幕出现 
注意此时新对象的名称将出现在主屏幕的标题蓝栏中。 

绘制介质层 
要绘制微带低通滤波器的介质层，参考图 2—13中的介质尺寸，并按如下步

骤操作： 
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1． 从主屏幕上选择 Model I draw 出现绘画屏幕。 
2． 点击 3D Object > box  注意：此时一提示出现在窗口的底部的文字栏中，
指示你选择盒体的初始角位置。 

3． 移动鼠标到 x-y轴原点，点击左键以确定盒体的一角。 不必担心盒体的
角度是否精确地与原点重合，在你点击 确定盒体的对角线上的另一点
后，你可以设置盒体的所有坐标，并显示所有定义的盒体。移动鼠标到

盒体的另一角。注意到屏幕上会出现在屏幕上，其会随鼠标的移动面扩

大或缩小 
4． 点击鼠标的左键以确定盒体的另一角 
不必担心盒体的尺寸，你可以在显示出来的盒体模块上进行调整其大小。

参考图 2—15 的对话框，使用其中的数据定义你的盒体。注意图 2—15
中的对象命名为 didectric 

5． 当模块中的内容满足你的要求后，点击 ok 这时介质层已绘成如图 2—16
所示 

6． 参考 2—17 中的对话框，使用显示的尺寸和其他数据。注意到图 2—17
中的对象被命名为 airbox 

7． 当盒体模块中的数据和信息满足你的要求时点击 ok所画的空气盒体，如
图 2—18 所示。注意到空气盒体和介质块是参数化的对象可以用
Edit>object parameters命令在任何时间对他们进行编辑。 

为绘制微带电路定义一个二维平面。 
为绘制微带线之前，先定义一个放置微带线的平面，为使微带位于介质层的上部，所定义的

平面应高于原点 25mil，即与介质层等高 
1． 点击命令：Defne>plane 
一盒体以 cross hair的方式显示出来，在文体区显示了原点提示 
2． 将光标移到介质层的最高点，点击鼠标左键显示信息，选择 x 轴键入
坐标或键入‘V’—表示相对。 

3． 移动光标至介质层上部的另一角，点击鼠标左键这时显示与上面 3 中
相同信息。 

4． 移动光标到介质层上部的第三个角，再次点击左键，这时定义平面的
对话框出现在屏幕上。 

5． 给平面命名为 mstrip-plan，如图 Fig2-19图。 
6． 点击 Apply然后点击 Done。 
此时平面 mstrip-plane 被加入平面列表中，当对象一旦绘制成，此平面就
成为缺省平面。 
绘制微带电路 
为了绘制微带电路，使用多线绘制命令 Polyline 使用屏幕下部的文本区，
输入每一点的相对位置偏离数据 

绘制微带电路： 
1． 以绘画屏幕，点击 2D objects>Polyline要给绘制多线输入一系列的点将
点击它们之间的连线，当使用键盘来完成此项工作时，一般先在 u-v
坐标系统中画出一绝对坐标组，以确定第一点。然后使用相对偏置，

使每一点都得到相对于前一点的偏离位置。 
2． 键入 0，185然后回车，这样第一点就被置放在介质的边缘上，文本区
中提示你选取或输入另一点，或键入‘r’以输入相对偏离距离数据。
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注意：你可以删除你所加入的任一点，这可以电机鼠标的右键进行。

点击 ESC键可完全退出 Polyline命令状态。 
3． 键入‘r’文本区显示如下信息‘选择下一点或输入相对偏离数据或键
入‘a’，表示绝对位置’ 

4． 输入 0，-12.5，回车。这时第一条线就画在屏幕上 
5． 输入剩下的点的位置，每输入一个点回车一次。 
70,0 
0,-60 
45,0 
6,65 
65,0 
0,-125 
25,0 
0,125 
65,0 
6,-125 
0,165 
45,0 
0,60 
70,0 
0,125 
-385,0 
最后一个点的位置输入后，线段形成封闭，组成了一个 2维对象。这时一
2维对象完成对话框会出现在屏幕上。 
6． 在对象名称框中，输入 microstrip，然后点击‘ok’,所点的微带电路，
以一组线段表示，如图 2-20图所示。 

保存微带低通滤波器文件。 
点击 File>save命令，随时在绘制操作中保存文件是一个好的习惯。特别是
在绘制较复杂的结构时是很重要的。 
当你点击 File >Return to Main，返回主屏幕，这时会显示出一模拟对话框。 
列表给出那一个对象是可视的。（这时一大写的 V字母出现杂对象名字前）
那些对象被选择为用于模拟（这时一个大写的字母 S出现在相关的对象的
名字前）。所有的你用来创建其他对象的对象都与创建的对象一起保存，

除非你用命令删除它们。 
虽然如此，它们并未显示在当前对话框中，也是不可见的。 
如果你需要他们创建另外一些对象，你可编辑它们的参量，在绘制时会自

动更新所作的修改。对本例来说，三个子对象显示在对话框中，即介质层，

空气盒体及滤波器微带电路。 
你可以对每个对象进行材料设置，因为你在屏幕上可以看到这些子对象，

它们被标明是可视的。确定它们同时被标明是用于模拟的对象（S）然后
点击 OK保存对象，然后返回主屏幕。 
这样你就完成了微带低通滤波器的绘制任务。 
 
绘制角天线和螺旋天线两节略去。 
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下面为第三部分。 
3-1材料的设置 
如同第二章所述，你在你绘制其结构时可设置结构的组成材料。在定义 2
维或 3维参数的绘制模板中，允许你设置对象是否用于模拟及材料的属性。 
显示在模板中的材料是你已包含在材料数据库中的那些种类。如果要使用

数据外的材料，可使用主屏幕菜单中的命令Materials>Assignment。 
材料的类型： 

 使用材料对话框来定义下列种类的物质的适当的值： 
 有耗或无耗金属 
 各向同性或各向异性介质 
 半导体 
 电阻 

金属： 
被指定为金属的对象可以是完善电导体或是有耗物质。 
有耗金属具有一电导率值，利用此值系统模拟器会给出一个精确的表面阻抗近似 
介质： 
当一对象定义为介质时，它可以是各向同性的或是各向异性的。 
使用磁损耗正切来定义有损耗介质。 
使用电损耗正切来定义有耗电介质 
介质： 
当一对象定义为介质时，它可以是各向同性或各向异性的。 
使用次损耗正切来定义有耗磁介质。 
使用电损耗正切来定义有损耗电介质。 
半导体： 
半导体材料，例如硅半导体。 
可以是 2维或是 3维的对象，你定义起特性：以电导率或是电阻率的形式，这两个参量

是互为倒数的。当你输入一个参量后，系统会对另一参数一倒数形式进行更新。 
对半导体还可以输入起介电常数和磁导率。 
电阻： 
虽然电子高度依赖于加工，最典型的是作为一 2维对象来建模，并用每平方单位的欧数

来定义。如果你要将一电阻作为三维模型来模拟，你必须输入一电阻率，单位是欧姆米。 
注意，结构的模拟及有耗材料的特性计入任意结构在模拟时可以上有耗的或是无耗的。

模拟时计入损耗的优点是： 
 对某些种类的结构可得到更加精确的逼真的结果。 
 使用有耗定义，可用以模拟一负载（电阻）有耗负载，终端以及包含完善导体如金
和铜的结构。 

如不计损耗，精确地模拟这样的结构是不可能的。 
3-3 
同轴线 T型结的材料 
同轴线所含材料只有空气（不包含边界的组成）在第二章中，当 
绘制其结构时指定其中的材料是很方便的。 
对同轴 T型结例子，要查看其材料的指定。 
可进行如下操作： 
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1． 从系统对象管理对话框，打开 coax在对象（如果在前面第二章的学习中，你已完
成其结构图的绘制，或者打开预先划好的同轴 T型结对象） 

2． 从主屏幕点击 materials-Assignment此时材料定义对话框显示如图 3-1。 
注意对象 coaxtee已列入对象表中，并定义为空气。 
3． 在对象表中点击空气。 
4． 点击 Edit Material 
介质定义对话框显示出来，如图 3-2 所示。注意这里空气同时具有相对介电常数，定义
为 1，它们是适当的。 
5． 点击 Cancel已退出此对话框。 

微带低通滤波器材料 
微带低通滤波器含空气层和介质层和金属微带电路。每一对象都定义为一种材料。并都具有

自己的一组特性。 
指定微带低通滤波器材料。 
1． 以对象管理对话框中（在主屏幕中选 Project>Project） 
打开对象 lpfilter（前提是在前章学习中尼以完成结构图的绘制 
否则可打开 Examples中预画好的对象 ms_lpf 

2． 从主屏幕中点击Material>Assignment则相应的材料对话框显示出来。 
3． 从对象列表中，点击 3Dobject airbox, 
然后在材料表中，点击空气。 

4． 从对象列表中，点击介质 
5． 在物质名称栏中，点击氧化铝 
6． 在物质类型表中，点击核实框介质选项。由于氧化铝是一种各项同性材料，故无须点击
各项异性核实框。 

7． 点击新材料（new Material） 
屏幕上显示出介质定义对话框 
8． 使用如图 3-3的典型氧化铝参量。 
9． 点击 ok 
10． 从对象列表中点击 2d Object Filter,然后在材料表中点击金属 
11． 点击 Edit Material 屏幕上显示出金属定义对话框 
12． 如果 perfect Conductor 一向已被选中，则点击它可转为非完善导体。 
13． 填入图 3-4中所显示的电导率和磁导率，然后点击 OK 

这样我们就定义了微带低通滤波器中的材料。 
后面，当你定义结构的边界，端口时，对此结构将定义两个端口以及电对称边界。 
 
角锥天线的物理 
在角锥天线的例子里，角锥天线和围绕天线的空气盆体都是由空气组成的。 
可以在绘制图形时，指定其组成材料，也可以现在定义它们，即Material>Assigment。 
步骤如下： 
由系统中的对象管理对话框（从主屏幕中的 Project>project）打开对象 horntutor（如果

在第二章中你已完成对象的绘制，否则可以打开事先以画好的例子，方法如前）。 
具体材料指定步骤为： 
1． 从主屏幕开始，点击Material>Assignment，出现材料定义对话框。 
2． 点击每个 3D对象（角和空气盒），并选用空气作为它们的材料。 
3． 点击“ok” 
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在下一章中，你在定义端口和边界时，可以定义为辐射边界，以使得电磁能量可以通

过喇叭口和空气盆向外辐射。 
 
边界的设置    4-1 
为对象结构定义边界，使得电磁模拟器可以升入结构体的构成材料的特性。 
定义端口是为了让模拟器知道能量是从哪里进入的，从什么地方离开的。 
注意： 

 在加入边界前你至少应在结构中确定一个对象以用于模拟。 
 在加入边界前用于模拟的对象的材料都应设定。 
注：边界的设置如同绘画，最终目的是使软件能“看见”和认别边界，所以设置边界

的命令是重要的。唯一的例外是端口的设置。端口的设置优先与其他边界。 
例：边界的设置有如下例子： 

 同轴 T型节 
 微带低通滤波器 
 角天线 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



http://www.mweda.com             专业提供 ADS,HFSS等微波仿真软件及其学习教程 

 14

同轴 T 型结由一个同轴传输线构成，此同轴线具有内导体和外导体。参考图 4
－1，观察各种边界。 
    此同轴结有三个端口，由于它具有磁对称被剖成一半 
    其边界的定义步骤如下： 
1． 由系统的对象管理对话框，打开对象 coaxtee 
2． 从此对象的主屏幕上，点击 Boundaries>Add，此时屏幕上出现定义端口和

边界的对话框，如图 4－2所示 

4－4 端口的定义 
    同轴 T型结具有三个端口，定义它们的步骤如下： 
1． 从端口或边界条件对话框，点击 Enter Number of Port and Modes(输入端口

和模式数目)，注意缺省设置是两个端口，各个端口一个模式 
2． 根据图 4－3中的数据填好对话框中的各栏，然后点击 ok 
    在同轴 T 型结的例子中，设置设解主模式和说第一阶模式。在这里你可以
输入任意个模式，即也可以对高阶模式解对应的电磁场问题。注意，虽然你可以

解任意个模式的电磁问题，但是你应限制你真正需要的模式的个数。 
    你定义的模式越多，解的结果 S矩阵就越复杂，模式个数越多的解所需时间
也越长。 
    注意：多个阻抗设置为 0.5，由于同轴 T型结具有 H面对称，如不采用对称
剖切技术，所需的模拟时间是现在的两倍。因而 Impedance Multiplier 一栏设为
0.5 以精确地计算原结构的阻抗。要设置阻抗倍增器，应首先点击选择端口和分
配模式列表中的每个端口，然后在阻抗倍增器一栏中键入 0.5 
3． 在表中在 Port#1,点击 1 
4． 当进行操作时应确定要处理的端口，然后点击 3Point Plane。这时出现对

话框，使你可以看见整个结构，在要定义端口的平面上点击三点。使用

snap 功能，选定一个平面是很容易的。如没有激活此功能，可以在
Windows>Project Preference对话框中激活 snap功能 

5． 将光标移至端口 1 上的某一点附近然后，点击它，参考图 4－1，端口的
分布。有一小 x在最高点表示已被选择。 

6． 将光标移至端口上的另两点，再点击他们。当一平面上的三个点被选择后，

一确定对话框会显示出来，而且该端口变成高亮状态 
7． 当该端口选择正确，点击 ok。这时，端口定义或边界条件对话框会再次

显示，一星号显示在 Port#1之后，表示此端口已定义。 
8． 用相同的步骤可选择端口 2和 3 

4－6定义边界 
   沿 y-z 平面的磁边界是在剖切结构时创建的。选择此平面，定义为对称的 H
面。当模拟器工作时会将此对称平面计入模拟计算中。对称 H 面边界的定义如
下： 
1． 从定义端或边界条件的对话框中的边界列表中点击对称 H 平面。注意，

此时一名为 Symmetric_H_Plane_4的边界列在边界名一栏中。可按你的意
愿修改名称，但现在使用此缺省名。 

2． 点击 3－Point Plane，出现对话框。可视结构图在所定义的平面上点击三
点，以确定要定义的边界。 
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3． 将光标移至对称平面上附近点击它，参考图 4.1中磁对称平面位置，在最
高点画有一小 x，表明它已被选择。 

4． 将光标移至到该平面上另两点上，并点击它，当一平面上的三点被选择后，

一确定的对话框出现，此时该平面高亮显示。 
5． 当对称平面选择正确，点击 ok 
    到此为止，你已定义了同轴 T 型结中所有必要的边界，注意：有许多其他
种类的边界，你可用于各种各样的结构类型，对于这些边界的细节，可参考 User’s 
Peference第十章中的“边界” 

4－7 边界的显示 

    为证实你所定义的端口和边界是正确的，你可以在任何时候显示检查它们，
所用的命令为 Boundaries>Display. 
要显示你已定义的同轴 T型结中的边界，可进行以下操作 

1． 点击 Boundaries>Display，这时 Display Boundary Condition对话框显示出
来，如图 4－4所示 

2． 点击各端口和边界，用不同的颜色表示它们，你也可以设置一刻度以便观

察。这时一外部边界被列入，虽然在前节你并未定义此外部边界。此外部

边界的定义是一种缺省，这里可以显示它。点击 Clear 和 Clearall 可擦去
所选择的所有边界 

3． 点击 Draw以显示所选择的边界。你可以绘制并显示一个边界或定义全部
边界，可用鼠标移动对话框到一边，以便观察结构图。 

4． 当你对所显示的边界无修改意见时，可点击 Done. 
    图 4－5中给出了同轴 T型结中的边界和各端口上的边界 

4－9 询问边界信息 
    在边界显示以后，如果你忘记了边界的定义，你可以询问每一边界以便观察
其名称。为此进行如下操作： 
1． 当所设计的边界显示在屏幕上时，可点击 Boundary>Query,信息“选择要

询问的边界窗口”显示在屏幕底部的文本框中。 
2． 点击任一窗口以显示该边界。屏幕底部的文本框中显示出该边界的名称。 

4－10定义端口校准线及阻抗线 
    对同轴 T 型结，可以预测最大的能量场的位置，故可以在各端口设置阻抗
线。 
    这些线便使得解对象的电磁场时计算阻抗线成为可能。对同轴线而言，对其
主模式能量场的最大处是以内导体边缘到外导体边缘成放射形状。校准线设定了

每个端口的相位的方向。当电磁模拟完成后，相位将按校准线的指向排列出来。

对本例而言，校准线和阻抗线是同一根线，所以对一个端口只需绘制一条线。 
对本例不需要极化线。极化线使得简并模式与极化线排列在一起。典型的极

化线应用是处理圆或方波导问题时，其中极化简并模式问题有可能存在。 
设置阻抗，校准线和极化线是一种选项，在解之前不是必要的一步。然而对

你的所有问题，定义端口校准线是一个好的习惯，它可以免除 S矩阵中 180度相
移的不确定性。对所有的结构定义阻抗线也是一个好的习惯，这样你就可以计算

功率－电压及电压－电流阻抗。 
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注意：阻抗，校准和极化线是对于单个端口而操作的，确认对结构中的每一

个端口定义它们。参考 4－1图，观察端口的分布，阻抗和校准线的位置。 

4－11 解和显示电场 
    为证实你的阻抗线位置的正确性，你可以观察各端口上的电场，进行如下操
作： 
1． 使用工具栏或Window>Zoom命令放大端口 1 
2． 从屏幕中，点击 Boundary>Port Calibration，这样端口上的阻抗线，项准

线和极化线对话框会显示在屏幕上。 
3． 如它们还未被选择，点击 Port#1和Mode#1 
4． 保留频率和缺省值 10GHZ，保留标尺设置为 Full 
5． 点击 Solve and Display E Field，此时信息框“Computing the Port Solution”

显示出来。 
6． 当端口解完成后，可将 Impedance/Calibration/Polarization Lines 对话框移

开，以便观察端口 1的电场分布，如图 4－6所示 
因为你已设置了箭头的标度为 Full，所有的箭头的尺度都是相同的，它们
仅表示电场的方向。如你设置刻度为线性，则箭头的尺寸将变化，这样你

可观察其方向和场的大小。另外还可以设置为对数刻度，给出场强度的对

数变化和方向。 
7． 观察完成后，可点击 Clear命令，清除端口中所有箭头。 

4－15 绘制端口上的阻抗和校准线 
操作如下： 
1． 确认在Windows>Project Preference中对象点捕获功能已被激活 
2． 确认 Port#1和Mode#1处于高亮状态，点击 Impedance和 Calibration以在

其后放置核对标记 
3． 在标明为 Start的区域，点击 Pick Point这时对话框会出现，使你可以选择

该端口上的点，参考图 4－1。注意到阻抗线和校准线应起始于端口外导
体的边缘并指向内部，或者说从参考地指向信号线。 

4． 点击端口上外导体边缘上的一点 Impedance/Calibration/Polarization Lines
对话框再次出现。注意到对起始点的 X-Y-Z坐标值已填入 

5． 在标名 end的区域，点击 Pick Point这时对话框消失了，允许你在端口上
选取一点。 

6． 在端口上的内导体边缘上选取一点，对话框再次出现。这时端点的三维坐

标也已填入，而阻抗/校准线已在图中绘出，参考图 4－7 
7． 点击 Apply 
8． 重复上述步骤，绘出端口 2和 3的阻抗校准线，并确认点击 Apply，使它

们处于被使用状态 
9． 当所有的端口的线都定义后，点击 Cancel.这时对同轴 T 型结而言，端口

及端口的校准和边界都已定义，它可以进入解操作。 

4－15  微带低通滤波器的边界指定 
    微带低通滤波器要求有两个端口，一个为信号输入，另一个为信号输出。参
考图 4－8中端口和边界的位置。 
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    滤波器的外部表面作为缺省值是完善导体。另外，因为阻抗边界是由电导率
未定义的，此微带电路定义了阻抗边界。 
    如果知道最大的切向电场的分布处，可以对每一端口定义一阻抗线。并可定
义一校准线，以防止 180度相移的不确定性。对低通滤波器，对主模式电场最大
处在微带中间到接地板之间。 
    软件系统可计算每一端口的 Zpv和 Zvi阻抗。一般情况，阻抗 Zvi总是被计
算的目标，除非输出端口不包含导体。 

4－16 
    微带低通滤波器的端口的定义如下 
1． 从 HFSS的对象管理对话框中，打开对象 ms-lpf 
2． 从主屏幕，点击 Boundaries>Add,出现 Port or Boundary Condition对话框。 
3． 从上述对话框中，点击 Enter Number of Ports and Modes，出现定义端口和

模式数对话框。缺省设置值是两个端口，每个端口一个模式 
4． 点击 Port1 Modes1 Impedance1,以选择它 
5． 由于滤波器具有一个磁对称边界，在 Impedance Multiplier 一栏中输入 0.5 
6． 点击 Port2 Modes1 Impedance1,以选择它 
7． 再次在 Impedance Multiplier 栏中输入 0.5，然后点击 ok。这时 Define 

Number of Ports and Modes对话框消失 
8． 从 Ports and Boundaries Currently Defined 列表中点击 1 
9． 确认要定义的端口，点击 3Point Plane。对话框消失，使你可以在要定义

的端口平面上选取三点以定义该端口 
10． 将光标移到端口 1上的某一点，点击它，参考图 4－8中的位置。在最高

点画出了一个小写 x。它表明此端口已被选定 
11． 将光标移到端口平面另两点，并点击它们。将一平面中的三点被选择，会

出现一核实对话框，被选中的端口会呈高亮状态 
12． 当端口选择正确点击 ok。这时定义端口和边界条件对话框会重新出现，

在 Port1之后出现一星号，表示此端口已被定义 
13． 用相同的操作定义端口 2，可参考图 4－8 

4-18定义边界 
图 4-8所示的磁对称边界，是通过仅给出滤波器图形的一般来建立的。 
选择此平面，将它定义为对称|H 平面，系统电磁模拟时会将此设置计入模

拟计算中。 
对称 H边界定义如下 

1． 从端口和边界条件的定义对话框中选择 Symmetric Hplane。缺省时，其名
称为 Symmetric_H_Plane_3，此名称是可以改变的，但现在使用此缺省名。 

2． 点击 3Point Plane，出现对话框，使你能看见整个结构，点击对称平面上
的三点。 

3． 将光标移到微带电路的对称平面上的某一点并点击它。会在最高点出现一

小 x，表示此点已被选择。 
4． 同样选择对称平面中的另三点。当三点都被选择后，会出现一个核实对话

框。该对话框平面成高亮状态。 
5． 当对称平面选择正确时，点击 ok。这样微带低通滤波器中所有必须的边
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界已都定义了。 

4-19 端口校准线 
对低通滤波器而言，最大电路的分布是可以预测的，因而可以设置端口的

阻抗线和校准线，以便于系统在进行电磁模拟时计算相应的阻抗。 
对低通滤波器，对主模式电场最大处在每个端口的中间，穿过介质位于接

地板之间。由于利用磁对称的便利，滤波器电路被切成一半，所以阻抗线和校准

线都位于对称面 H中。 
校准线给出了滤波器端口上信号的相位的方向。当电磁模拟进行时，既以

次校准线作为排列的基准。 
在本例中，校准线和阻抗线是重名的，故每端口仅画一条线即可。本例不

需要极化线。注：如果使用阻抗线，校准线或极化线，则应确认在端口都给出定

义。对本例，它们的定义，可参考图 4-8 

4-20 阻抗线和校准线的绘制 
1． 确认点捕捉功能已被激活。相关窗口是Windows>Project Preference 
2． 从主屏幕上，选择 Boundaries>Port Calibration 
3． 确认 Port#1和Mode#1处于高亮状态，点击阻抗和校准，将核对符号加在

其后。 
4． 在标有 Start地方，点击 Pick Point。出现一对话框，你可以在该端口选取

一点，参考图 4-8，注意阻抗线和校准线应以端口的底部边缘开始指向上
部。 

5． 点击端口 1 底部的外角。对话框 Impedance/Calibration/Polarization Lines
重新出现。这是注意到，起始点的 X,Y,Z坐标在对话框中已出现。 

6． 在标有 end的区域点击 Pick out。这时对话框出现，使你可以在此端口选
取点 

7． 点击端口 1 的上部角，这时重新出现 Impedance/Calibration/Polarization 
Lines对话框 

8． 点击 Apply。这时端口的 x,y,z坐标出现，端口上的 Impedance/Calibration
线已画出。 

9． 点击 Port#2，并重复上述操作，已画出端口 2的阻抗和校准线。在选取该
点之后，确认点击 3Apply。 

10． 各端口的线定义完之后，点击 Cancel，画出的线应如同图 4-8所示。此时，
微带低通滤波器在电磁模拟前的各项准备工作都已完成。 

11． 点击 Project>Slove以保存端口的校准工作。 

4-21 角天线边界指定 
对角天线仅需要一个端口让信号馈入。电磁能量在天线的另一端辐射出去，

以产生独特的辐射模型。参考图 4-9，观察各端口的位置和剖分边界。图中仅为
实际天线的 1/4。 

角天线边界的定义： 
1． 从 HFSS中的对象管理对话框中，打开对象 horntutor 
2． 从对象主屏幕中，点击 Boundaries>Add。此时，端口或边界条件对话框出

现。 
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4-22定义端口 

角天线只有一个端口，定义操作如下： 
1． 从端口或边界条件定义对话窗口中点击 Enter Number of Ports and Modes，

注意缺省项为两个端口，每个端口一个模式。 
2． 确定一个端口，一个模式。 

对角天线而言，具有两个对称面：一个磁对称面，另一个是电对称面。在

Impedance Multiplier 一栏中填入 1 是恰当的。这是因为对称面对应的
Impedance Multiplier值是 2，而磁对称面对应值为 0.5，二者乘积为一。
这时‘端口或边界条件对话框’重新出现 

3． 端口定义：点击 3 Point Boundaries Plane这时你应选择一有边界平面，而
不仅是一平面。因为空气盒的一端面和天线的输入端口所在平面使重合

的。用点捕捉功能 Snap，确定一平面是很容易的。 
4． 将光标置于天线端口的最高点，并点击它。端口的位置可以参考图 4-9。

如前，小写 x的出现，表示该端口已被选择。 
5． 在选定端口上另两点，在屏幕底部的文本栏中会出现信息，要求你选择一

平面。 
6． 将光标置于角天线底部的输入口平面上，点击它，然后回车。一确认信息

会出现，你所选择的端口处于高亮状态。 
7． 当端口被正确选择，点击 ok。重新出现端口或边界条件对话框，在 Port#1

之后出现*，表示 Port1已定义。名称‘Port_1’出现在已定义端口和边界
的列表中。 

4-24 辐射边界的定义 
在角天线中，空气盒中应确定一平面为辐射边界。此类型的边界使得所模

拟的结构具有一合理大小的空间以辐射度电磁能量。这种类型的边界又称为吸收

边界条件。 
其定义如下： 

1． 从端口或边界条件定义对话框中点击 Radiation 作为边界的类型。出现边
界选择命令对话框。 

2． 点击 Object Name出现相应的对话框。可以使用对象的名称，因为整个角
天线结构中的空气盒会得到此辐射边界条件。 

3． 点击 airbox，再点击 ok。出现确认对话框，这时空气盒处于高亮状态。 
4． 点击 ok。这时，已定义端口或边界名称列表中出现 Radiation_2. 

4－25 定义导体边界 
    在本例中，角状零件应被定义为导体。即角天线是由金属包围的，中间由空
气构成。 
    导体边界定义为： 
1． 由端口或边界条件定义对话框中点击 Conductor作为边界类型。 
2． 点击 Object Name。边界选择命令对话框出现，点击 horn1再点击 ok。出

现一确认对话框，而 horn 处于高亮。注意到在已定义端口或边界名列表
中‘Conductor_3’已显示出来了。在本例中，使用缺省项导体边界数据。 

4－26 对称平面边界 
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    由于本例中包含有两个方向上的对称面，你必须从两个方向上剖切角天线。
故最后求解的空间仅为原来的 1/4。 
    对称面的定义 
    Symmetric H Plane定义 1－5如前低通滤波器的定义。 
6． 端口或边界定义对话框中点击 Symmetric-E Plane作为边界类型。 
7． 点击 3 Point Plane 

对话框出现，你可观察到整个结构，并可在所要定义的电对称平面上选择

3点。激活 Snap功能，以便于端口定义。 
8． 将光标置于角天线的 y-z平面上的最高点附近点击它。点对称平面的位置

可参考图 4－9。同样会出现一 x表示它已被选择。 
9． 同样可在 E 对称平面上选择另两点。三点都选定后，会出现确认一对话

框。该平面将显高亮。 
10． 如对称面选择正确，点击 ok。名称 Symmetric_E_Plane_5将出现在现已定

义的端口或边界的列表名单上。 

4－28 定义孔边界 

    在前一步操作中，角天线的孔被金属所封闭。现在你需要重新存孔平面的自
然边界，使其能够向外辐射电磁能量。 
    其操作是指定一个边界，重新存储此含有辐射口的边界条件。 
    记住指定边界的命令是重要的。所以先定义导体边界是重要的，然后在开口
处使用‘重存储边界条件’移去金属边界。 
    定义孔的 restore boundary 如下 
1． 从端口或边界定义对话框中点击 restore作为边界类型。 
2． 点击 3 Point Plane。对话框出现，在孔所在平面选取三点以进行定义，同

样可使用 snap功能。 
3． 置光标到角天线上辐射孔的最高点上，点击它。可参考图 4－9，小 x 

的出现表示此点已被选定。 
4． 重复操作，以选定另两点。当三点都选定后，确认对话框出现孔呈高亮状

态。 
5． 如上述选择正确，点击 ok。这时 DEFAULT_6 出现在一确定端口和边界

列表中。此时端口或边界定义对话框中的内容如同图 4－10所示。 
6． 点击 Done。此时上述对话框显示出来。这样你定义了所有的边界，此时

保存你的对象是明智的，用 Project>save命令进行保存。 

4－30－4－31阻抗及校准线定义 
参考前例，这里略去 

4－32 输入一电压源 
    一般可使用一电压源来分析一内部端口，或分析一耦合线，如图 4－11中的
例子所示。 
    本节给出为分析微带耦合线而设置的电压源，如图 4－11所示。 
    电压源的设置如下： 
1． 将包围结构的盒体向外扩展一小段（一般为 1/4波长）注意在图 4－11中，

为了便于观察这种扩大，画的较长。 
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2． 从主屏幕点击边界>电压源。这时 V/I源对话框出现在屏幕中。 
3． 点击 Enter Number of Sources 
4． 输入 4，这样你在耦合微带线的 4个多口各加上一电压源，然后点击 ok 
5． 在源列表中（Source#）中点击 1 
6． 对此电压线命名，或使用缺省名称 Source_1 
7． 输入电压源 
      在端口上可以输入起始点和中止点的坐标或点击在想要加入源的边缘或
表面。 
      如果你选择一个边缘或表面，在此后你可以在所出现的对话框中编辑 x,y,z
坐标值。点击 Apply将源加入结构。 
8． 用相同的操作定义，耦合微带线的其他三个端的源，每个定以后，都要点

击 Apply，最后点击 Cancel，退出定义。 
9． 定义电压源的另一个选择是画一条从微带中部垂至于基片到底部的线。如

图 4－12所示 

 

5． 解 
    本章给出指南例子，包含如下内容 
*设置一个问题的解 
*运行解 
*使用工作控制来监视解的进程。删除解，决定解的模式：顺序或并行进行，在
任意时刻中止解的进行。 
    在本章中我们将设置解下列问题 
*同轴 T型结  
*微带低通滤波器 

*角天线 
在进行解之前，你需要完成前面 2，3，4章的各项操作，即结构绘制，材料

的定义和边界的设置。 
    也可以打开 example目录下事先给出的例子。 
    关于解的详细描述可在‘使用者参考’文献中的十一章中找到 

5－2 解的设置 
    Solve>Setup对话框中有解的选项。 
    包括： 
×输入起始网络－初始的，先前的或最后的网格 
×保存解的数据，包括主模数据或是所定义的所有模式的数据 
×保存所有频率点下的数据，或是最后一个数据 
×细化选择：全局或三角 S参数矩阵的判据中止，细化处理数目 
×对一特别频率的细化，在缺省情况下细化仅对最高频率点进行 
×网格的初始化－仅用于特殊情况下，即对象非常复杂，未知量太大 

5－3 解的运行 
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    当解的设置完成后，可用 Solve>Run命令解开始运行。Solve>Run执行后出
现一对话框：可在当前的计算机上或你定义的遥控计算机上进行运算。 
    本章例子中，假定运算在你的本地主机上进行。对如何设置遥控计算机进行
HFSS模拟运算，请参考使用者手册（User’s Reference）第十一章 解 
    注意，对于不同的问题，解所需要的时间是不同的。对于同一问题解的时间
取决于硬件条件。如内存大小，如在网络上运行还取决许网络的流量等因素。 

5－4 解的工作控制 
    Solve>Job Control命令，可提供模拟状态观察。当你点击它后，将出现 Job 
Control对话框。在此对话框中，可以得到数据收敛的情况，距离收敛解的程度。
还可中止解。 
    收敛图： 
    从 Job Control对话框，点击 Plot可观察当前数据的收敛情况。 
    从收敛绘画对话框，可选择 Delta S （给出 Delta S与间隔的对照图，或是 S
参量的幅度和相位图），从数据的变化趋势可以分析出数据的收敛情况。 
    解的批处理： 
    要依次进行一批对象的处理，可点击 Solve>Run以设置时间。每个对象占据
一定大小的内存而同时进行计算。然而，应注意大的对象将需要很对计算机内存

空间。如选择同步模拟，大的对象需要用很长的时间 

5－5 同轴 T型结的设置 
要解同轴 T型结，设置如下： 

1． 从 HFSS对象管理对话框中打开对象 coaxtee 
2． 从主屏幕，点击 Solve>Setup，出现模拟对话框 
3． 使用主设置标记（tab）设置 coaxtee仅对网格的初始化和主模求解，参考

图 5－1 
4． 点击细化选项标记，并定义一全局 Delta S参数 Delta误差仅为 0.01（缺

省值） 
5． 将 Limit the number of additional refinement passes设置为 5，参考图 5－2

所示 
6． 点击离散频率标记，将对象解的频率设置为 2GHZ 
7． 点击 Add按钮以增加离散频率列表中的频率，参考图 5－3 

5-8 解同轴 T型结 
操作如下： 
1．   主屏幕中，点击 Solve>Run，出现运行对话框，可以设置运行主机名称

及开始 运行的日期和时间。 
2． 点击 ok。HFSS 的工作控制对话框显示在屏幕中，如图 5－4 所示。当解

完成后，信息‘Done’会显示出来，伴随的信息还有完成的日期和时间。 

5－9 微带低通滤波器的设置 

1． 从 HP HFSS对象管理对话框，打开 lifilter 
2． 从主屏幕，点击 Solve>Setup。出现 HPHFSS模拟结构对话框。 
3． 使用主设置标记设置模拟对主模式进行并且先初始化网格，参考图 5－5 
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4． 点击细化选择标记，选择全局 Delta S参数，Delta误差为缺省 0.01 
5． 将细化附加限制数为 5，参考图 5－6 
6． 点击离散频率标记 
7． 设置扫频的开始频率和结束频率。开始频率为 2GHZ，结束频率为 16GHZ，

其中含 14个线性点。 
8． 点击 Add，将上述频率填入离散频率表中，参考图 5－7。这样微带低通

滤波器的模拟前设置工作就完成了。 

5－12 微带低通滤波器的模拟 

1． 从主屏幕中选择命令 Solve>Run，出现运行对话框。在此对话框中可以设
置运行主机，及其运行的日期和时间。 

2． 点击 ok。解的过程开始了 Job Control 对话框显现，当模拟完成，信息
‘Done’会出现，并出现完成日期和时间。 

5－13－5－17角天线设置和运行略去 

6－1后处理 

    数据后处理含图的绘制和观察，有如下选项： 
1． S参数数据 
2． 电场及磁场的图示 
3． 传播常数 
4． 特性阻抗 
5． 多平面层次图及结构的场截面图 
6． Smith圆图 
7． 箭头矢量图 
8． 远场图绘制 
9． 2维场图 
    详细说明可视 User’s Reference 

6－2 建立同轴 T型结的层次图 
    Shaped Plot创建： 
1． 从 HFSS Project管理对话框，打开对象 coaxtee 
2． 从主屏幕，点击 Post>Post Processor,后处理对话框出现。 
3． 点击 ok。信息‘Starting Post Processor’出现，后处理屏幕显现，如图 6－

1。 
4． 从上述屏幕中的菜单里选取 Plot>field plot,场绘制对话框出现，如图 6－2 
5． 完成对话框中的选项 
6． 点击 ok。Y-Z平面的多层次图显示在屏幕上，y-z平面为对称平面。 
7． 点击 Animate 之后的盒体。这时，多层次图变得可动视图，表示电路沿

y-z平面运动通过整个结构。 
8． 在任意点再次点击 Animate，以停止运动。如图 6－3所示。 
你可以使用滚动条以最小值变化到最大值，以移动，冻结在图中的位置。 
可点击 logscale来规定颜色刻度，对数变化的色调使得对比度最大。 
使用 Translucency下的滚动条以增加或减少图的半透明度。 
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将滚动条置于左边，可观察到层次图。 

6－5 旋转，标定刻度及图形的移动 
    可用屏幕下部的控制菜单来旋转，放大或缩小或移动图形。 
    使用动态旋转： 
1． 点击 Rotate 
2． 将关标置于图上，拖动鼠标上下垂直的旋转图。左右拖动可水平旋转图。

点击 Scale或 Pan，移动光标至图中，拖动鼠标可放大或缩小或移动图 

6－6 创建 S矩阵图－微带低通滤波器 
×绘制 S矩阵数据图 
×显示多角度视图 
S参数图： 
1． 从 HFSS对象管理对话框，打开 lipfilter对象 
2． 从对象主屏幕中，点击 Post>Post Processor，后处理对话框显示出来。 
3． 点击 ok，‘Starting Post Processor’信息出现，系统暂停加载后处理器。后

处理屏幕显示。 
4． 从 Post Processor菜单中，点击 S_Display>S Mag Plot,S参数绘制对话框出

现 
5． 从矩阵表中，点击包含扫频数据的解。在本例中，列出的是第一解 
6． 从 S参数表中，点击 S【(P1M1)，(P2M2)】 
7． 从视图表中点击 View1，对话框如图 6－5所示 
8． 点击 ok，绘出的 S矩阵图，如 6－6所示 
9． 点击 S_Display>S Mag Plot again 
10． 从 S矩阵绘制对话框中，点击 S【(P1M1)，(P2M2)】及 View_2,然后点击

ok。S12辐射与频率对照表图显示出来。 
11． 用上述相同的操作可以在 View_3，View_4中设置 S21,S22图 
12． 当四个设置完成后，点击Window/Tick，在屏幕上显示四个图，如图 6－7。

注：你点击任意图后，可使它活动起来。用屏幕底部 x,y轴控制改变其刻
度，改变图的颜色，盒体线的类型等等。 

6－9观察远场图：角锥天线 
    因为角锥天线含有一辐射边界。除了其他可视图外，还可以画远场图，立体
场数据图和天线参量。 
    本节含：○创建一远场图 
            ○创建一远场极座标图 
            ○天线参量 
创建远场图 
1． 从 HFSS对象管理对话框中，打开 hornutor对象 
2． 从对象主屏幕，点击 Post>Post Processor,后处理对话框出现 
3． 点击 ok,出现信息‘Starting Post Processor’ 
4． 从后处理中点击 Far Field>Far field Plot,远场图对话框显示出来。 
5． 使用 View_!,点击 ok。系统暂停，远场图绘出，如图 6－8。可用半透明滚

动条，调整视图 
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6－11创建极坐标图 
    从远场图中，你可以调整常数 Theta和常数 Phi值，来创建一个 2维截面极
坐标图。 
    创建远场极坐标图过程如下： 
1． 从远场中，使用常数 Theta 和常数 Phi 值下的滚动条，当 Theta和 Phi 角

变化时，一截面显示在图中。 
2． 点击 Save Constant Plot or Save Constant Phi Plot 
3． 选择 Far field>Far field Polar Plots 
4． 从远场极坐标图对话框中，选择以保存的极坐标图的常数值，点击一视图。

然后点击 ok。如图 6－9中所显示出来的极坐标图。用此方法你可以保存
并显示多个截面图 

6－12 观察天线参量 
    天线的一些其他参量也与远场数据一同计算出。当执行快速频率扫描时，这
些数据在中心频率点上与电磁模拟一道被计算出来，并从中心频率（插值）外推

到扫描频率点上。 
    从 Post Processing Screen，点击 Far Field>Antenna Parameters. 
    天线对话框显示出来，如图 6－10所示。表中提供了很多 2维和 3维绘图变
量。 
  



 

 

 

微波 EDA 网视频培训教程推荐 

 

微波 EDA 网(www.mweda.com)成立于 2004 年底，并于翌年与易迪拓培训合并，专注于

微波、射频和硬件工程师的培养，现已发展成为国内最大的微波射频和无线通信人才培养基地。

先后与人民邮电出版社、电子工业出版社合作出版了多本专业图书，成功推出了多套微波射频

经典培训课程和 ADS、HFSS 等软件的使用培训课程，广受工程技术学员的好评，帮助数万名

工程师提升了专业技术能力。客户遍布中兴通讯、研通高频、埃威航电、国人通信等多家国内

知名公司，以及台湾工业技术研究院、永业科技、全一电子等多家台湾地区企业。 

 

 

 

 

HFSS 中文视频培训课程套装 

国内最全面和专业的 HFSS 培训教程套装，包含 5 套视频教程

和 2 本教材，李明洋老师讲解；结合最新工程案例，视频操作

演示，让 HFSS 学习不再难。购买套装更可超值赠送 3 个月免

费学习答疑，让您花最少的成本，以最快的速度自学掌握

HFSS… 【点击浏览详情】 

 两周学会 HFSS —— 中文视频教程 

李明洋主讲，视频同步操作演示，直观易学。课程从零讲起，通过两周的课程学习，可以

帮助您快速入门、自学掌握 HFSS，真正做到让 HFSS 学习不再难…【点击浏览详情】 

 HFSS 微波器件仿真分析实例 —— 中文视频教程 

HFSS 进阶培训课程，中文视频，通过十个 HFSS 仿真设计工程应用实例，带您更深入学

习 HFSS 的实际应用，掌握 HFSS 高级设置和应用技巧…【点击浏览详情】 

 HFSS 天线设计入门 —— 中文视频教程 

HFSS 是天线设计的王者，该教程全面解析了天线的基础知识、HFSS 天线设计流程和详

细操作设置，让 HFSS 天线设计不再难…【点击浏览详情】 

 PCB 天线设计和 HFSS 仿真分析实例 —— 中文视频教程 

详细讲解了 PCB 天线的工作原理和设计方法、如何使用 HFSS 来设计分析 PCB 天线，

以及如何借助于 Smith 圆图工作来调试天线的匹配电路，改善天线性能…【点击浏览详情】 

 

了解详情，请查看微波 EDA 网（www.mweda.com/eda/hfss.html） 
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微波射频测量仪器培训课程套装合集 
 

搞射频微波，不会仪器操作怎么行！矢量网络分析仪、频谱仪、

示波器、信号源是微波射频工程师最常用的测量仪器。该培训

套装集合了直观的视频培训教程和详尽的图书教材，旨在帮助

您快速熟悉和精通矢网、频谱仪、示波器等仪器的操作…【点

击浏览详情】 
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国内最全面和权威的ADS 培训教程，详细讲解了ADS 在微波射频电路、

通信系统和电磁仿真设计方面的应用。课程是由具有多年 ADS 使用经

验的资深专家讲解，结合工程实例，直观易学；能让您在最短的时间内

学会 ADS，并把 ADS 真正应用到研发工作中去… 【点击浏览详情】 

  

  

我们的课程优势： 

※ 成立于 2004 年，一直专注于射频工程师的培养，行业经验丰富，更了解您的需求 

※ 视频课程、既能达到现场培训的效果，又能免除您舟车劳顿的辛苦，学习工作两不误

※ 经验丰富的一线资深专家主讲，结合实际工程案例，直观、实用、易学 

※ 更多实用课程，欢迎登陆我们的官方网站 http://www.mweda.com，或者登陆我们的官

方淘宝店 http://shop36920890.taobao.com/ 
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国内最全面和专业的 HFSS 培训教程套装，包含 5 套视频教程

和 2 本教材，李明洋老师讲解；结合最新工程案例，视频操作

演示，让 HFSS 学习不再难。购买套装更可超值赠送 3 个月免

费学习答疑，让您花最少的成本，以最快的速度自学掌握

HFSS… 【点击浏览详情】 

 两周学会 HFSS —— 中文视频教程 

李明洋主讲，视频同步操作演示，直观易学。课程从零讲起，通过两周的课程学习，可以

帮助您快速入门、自学掌握 HFSS，真正做到让 HFSS 学习不再难…【点击浏览详情】 

 HFSS 微波器件仿真分析实例 —— 中文视频教程 

HFSS 进阶培训课程，中文视频，通过十个 HFSS 仿真设计工程应用实例，带您更深入学

习 HFSS 的实际应用，掌握 HFSS 高级设置和应用技巧…【点击浏览详情】 

 HFSS 天线设计入门 —— 中文视频教程 

HFSS 是天线设计的王者，该教程全面解析了天线的基础知识、HFSS 天线设计流程和详

细操作设置，让 HFSS 天线设计不再难…【点击浏览详情】 

 PCB 天线设计和 HFSS 仿真分析实例 —— 中文视频教程 

详细讲解了 PCB 天线的工作原理和设计方法、如何使用 HFSS 来设计分析 PCB 天线，

以及如何借助于 Smith 圆图工作来调试天线的匹配电路，改善天线性能…【点击浏览详情】 

 

了解详情，请查看微波 EDA 网（www.mweda.com/eda/hfss.html） 

 

http://www.mweda.com/eda/hfss.html
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微波射频测量仪器培训课程套装合集 
 

搞射频微波，不会仪器操作怎么行！矢量网络分析仪、频谱仪、

示波器、信号源是微波射频工程师最常用的测量仪器。该培训

套装集合了直观的视频培训教程和详尽的图书教材，旨在帮助

您快速熟悉和精通矢网、频谱仪、示波器等仪器的操作…【点

击浏览详情】 

 

 

 Agilent ADS 学习培训课程套装 

 

国内最全面和权威的ADS 培训教程，详细讲解了ADS 在微波射频电路、

通信系统和电磁仿真设计方面的应用。课程是由具有多年 ADS 使用经

验的资深专家讲解，结合工程实例，直观易学；能让您在最短的时间内

学会 ADS，并把 ADS 真正应用到研发工作中去… 【点击浏览详情】 

  

  

我们的课程优势： 

※ 成立于 2004 年，一直专注于射频工程师的培养，行业经验丰富，更了解您的需求 

※ 视频课程、既能达到现场培训的效果，又能免除您舟车劳顿的辛苦，学习工作两不误

※ 经验丰富的一线资深专家主讲，结合实际工程案例，直观、实用、易学 

※ 更多实用课程，欢迎登陆我们的官方网站 http://www.mweda.com，或者登陆我们的官

方淘宝店 http://shop36920890.taobao.com/ 

 

 

 

 

专注于微波、射频、硬件工程师的培养, 

网址：http://www.mweda.com  

Q Q：625774272 

 

 

 

 




